Dead - Confused!

nird
Posts: 10
Joined: 10 Oct 2012, 21:34

Dead - Confused!

Postby nird » 29 Oct 2014, 00:28

Hi Guys....

I have to old MS units which I have had sitting around as spares for quite a while.
As far as I am aware they just needed replacement elements.

I ordered replacements (both sides for both units) and fitted.

Both units are still dead.

I have tested the thermal fuse, measured the elements, tested cable, plug, etc. and at a complete lose.
I suspect the only thing left is the pcb however im more inclined to think there is something else or something I have stupidly done as find it hard to believe BOTH have faulty pcb when they were both working previously until elements were broken.

Original MS stylers with only S/S pcb.

Is there anything else I can try/test?

Is there a way to test and confirm pcb failure without having a known working pcb?

Thanks in advance!

gary
Site Admin
Posts: 1032
Joined: 26 Jan 2008, 00:44

Re: Dead - Confused!

Postby gary » 29 Oct 2014, 10:12

The elements now measure about 80ohms when both connected?

nird
Posts: 10
Joined: 10 Oct 2012, 21:34

Re: Dead - Confused!

Postby nird » 29 Oct 2014, 13:10

Hi Gary,

yes....both elements reading correctly on both sets.
Is there a way to test pcb?

thanks

gary
Site Admin
Posts: 1032
Joined: 26 Jan 2008, 00:44

Re: Dead - Confused!

Postby gary » 29 Oct 2014, 22:02

Not really. Generally if all else is good, then it must be the pcb.

Gary


Return to “GHD MS”

Who is online

Users browsing this forum: No registered users and 1 guest