Continuously cutting out

Shawaal
Posts: 2
Joined: 16 Jun 2016, 17:57

Continuously cutting out

Postby Shawaal » 16 Jun 2016, 18:00

Hello, my wife's SS2 goes on, solid red at first, then flashing red and it appears to be working fine, until the light starts going solid red again and intermittently back to flashing red......seems like its continuosly cutting out ? Can anyone point me in the right direction ? I've stripped it, checked continuity, no loose or broken wires.........any advice on what these symptoms could be pointing to would be appreciated.

gary
Site Admin
Posts: 1032
Joined: 26 Jan 2008, 00:44

Re: Continuously cutting out

Postby gary » 16 Jun 2016, 22:48

Hi Shawaal,

Do you get 80ohms on the heaters (when both connected) and less than 1 ohm on the heater element. Do any of the heater wires come adrift if you gently pull on them?

Gary

Shawaal
Posts: 2
Joined: 16 Jun 2016, 17:57

Re: Continuously cutting out

Postby Shawaal » 18 Jun 2016, 15:31

Hello Gary

Yes I tested again after your message and can confirm i get 80 ohms on the Heaters and less than 1 (0.4) on the heater element/thermal fuse.
All wires are secure and does not appear damaged. If you dont mind I'll send you some pics on your Facebook via direct message to check if you pick up something that i'm not seeing.
Not sure where to go from here or what spares if any to order.

gary
Site Admin
Posts: 1032
Joined: 26 Jan 2008, 00:44

Re: Continuously cutting out

Postby gary » 18 Jun 2016, 23:58

Hi Shawaal,

Is that 80ohms with the heaters both connected or one at a time?

Are the wires to the heaters secure?

Does the light ever go off during use? The red light is on when the heaters are getting powered, so going from flashing to on without going off is very odd!

Gary


Return to “GHD SS2”

Who is online

Users browsing this forum: No registered users and 1 guest