Dead MK4.2P

Webinfusion
Posts: 134
Joined: 20 Jan 2012, 02:13

Re: Dead MK4.2P

Postby Webinfusion » 10 Feb 2012, 21:30

Hi,
Would try changing C5, C5 is across the supply of the pic and i feel the voltage may be a bit low for the pic to start.

woody
Posts: 7
Joined: 06 Feb 2012, 17:10

Re: Dead MK4.2P

Postby woody » 11 Feb 2012, 11:18

Hi and cheers for the advice.

I was thinking of replacing the C5 after reading previous posts by you and others regarding it on this forum. However not having a clue what the info on the C5 meant I found the following info on the web http://www.avx.com/tantalum/data/NOJ/NOJE227_006.pdf

From the data sheet it has the C5 on this PCB as follows:-

Info on C5 227 J 30393 which the data sheet has it being 6.3 v and 220uF. I note the one recommended is 100uF, could different boards have different ratings? Would you suggest replacing like for like, go with the one suggested or have I got it all wrong?

Many thanks for your input which is greatly appreciated

Colin

Webinfusion
Posts: 134
Joined: 20 Jan 2012, 02:13

Re: Dead MK4.2P

Postby Webinfusion » 12 Feb 2012, 22:52

Hi,
Since C5 is across the supply of the PIC i can ony assume its being used as a smoothing capacitor so value should not be too important, but picking a lower capactance would not be my choice as it will cause more ripple to the PIC, if you can stay with the original value.

woody
Posts: 7
Joined: 06 Feb 2012, 17:10

Re: Dead MK4.2P

Postby woody » 13 Feb 2012, 13:20

Hi thanks again

Having succumbed to the pressure of my girl friend to sort them out ;) I've bought replacement pcbs, they are now working fine which goes to prove the problem was on one of the boards. I didn't try each one individually cos I didn't want to run the risk of damaging the new boards, so can't confirm which board was at fault.

However as I said before I've become obsessed with tracing the problem, so I've put the word out between family and friends for any unwanted broken GHDs . Hopefully I'll get to the bottom of the problem at some point in the future and report back if I do :geek: :lol:

Cheers for all the help.

Colin

gary
Site Admin
Posts: 1032
Joined: 26 Jan 2008, 00:44

Re: Dead MK4.2P

Postby gary » 14 Feb 2012, 13:48

Glad you got them sorted. The PIC supply voltage does sound a bit low so that's where I'd start....

Gary

prettypriddy
Posts: 28
Joined: 01 Oct 2010, 13:24

Re: Dead MK4.2P

Postby prettypriddy » 14 Feb 2012, 18:34

HOORAY!
Does this mean it`s the end of this thread.
I don`t wish to appear unkind but what a waste of time, it was always going to end with a new pcb.
It`s obvious the Poster knows his stuff electronics wise, perhaps not so much re Ghds.
But i reckon this was more a case of "My Fluke is bigger than yours"

mostertf
Posts: 4
Joined: 13 Aug 2018, 09:54

Re: Dead MK4.2P

Postby mostertf » 13 Aug 2018, 10:40

so to continue many years later haha.
ive got a broken ghd 5.0 with 3v accross the pic...
everything else is working but that 3v on pin 1 and 8 bothers me. has anyone checked what the actual voltage should be? my guess is 5v.
so im thinking my pic is not dead, usually when a pic dies on other devices it causes an internal short of sort.

im thinking ill start by sourcing a new c5 cap.
any hints or tips of what i should rather do or look for

gary
Site Admin
Posts: 1032
Joined: 26 Jan 2008, 00:44

Re: Dead MK4.2P

Postby gary » 13 Aug 2018, 14:52

Have you checked R8/R11? If they are high resistance the voltage on the PIC might drop.

Gary

mostertf
Posts: 4
Joined: 13 Aug 2018, 09:54

Re: Dead MK4.2P

Postby mostertf » 14 Aug 2018, 08:33

hi, yes i did check all the voltages and resistance measurements as specified in the other threads. all of them are correct within a 2-5% tolarance?

mostertf
Posts: 4
Joined: 13 Aug 2018, 09:54

Re: Dead MK4.2P

Postby mostertf » 14 Aug 2018, 08:46

im thinking of removing the pic and measuring the voltage across c5, should the voltage drop be due to a faulty pic, the voltage should measure 5v now accross pin 1 and 8? if i still get a 3v across those two pins (and across c5) it means the pic is fine and the components converting the 220ac to 5v dc is broken?


Return to “GHD 4.2P”

Who is online

Users browsing this forum: No registered users and 2 guests