ghds stopped working

Miranda192
Posts: 3
Joined: 19 Jun 2011, 23:58

ghds stopped working

Postby Miranda192 » 20 Jun 2011, 09:31

Hi,
My ghds were working perfectly -then whilst in use they made a cracking sound and just went completely dead.

I have changed the cable but they still remain dead. I purchased them of the main ghds site so not fakes.

Would anybody know what the fault could be?

Thanks for helping,
Miranda

brooksy
Posts: 4
Joined: 10 Jun 2011, 13:14

Re: ghds stopped working

Postby brooksy » 09 Aug 2011, 11:57

Miranda192 wrote:Hi,
My ghds were working perfectly -then whilst in use they made a cracking sound and just went completely dead.

I have changed the cable but they still remain dead. I purchased them of the main ghds site so not fakes.

Would anybody know what the fault could be?

Thanks for helping,
Miranda

Hi Miranda. Sometimes when you get a cable fault it causes power surges and causes the r8 resistor to blow. It is located under the non switched side cover. There may be 2 resistors (r8 +r11) depending on the age of your straightners.
Hope this helps
Marc

simon b
Posts: 1
Joined: 05 Feb 2013, 18:23

Re: ghds stopped working

Postby simon b » 05 Feb 2013, 18:39

Hi there,
Just bought a replacment cable for my ghd 4.0 still to find out theyre still not working. I know for a fact its not the cable cause ive tired it in my friends ghds and they work fine. Just wondering if you have any ideas on what next I should try cheers

gary
Site Admin
Posts: 1032
Joined: 26 Jan 2008, 00:44

Re: ghds stopped working

Postby gary » 05 Feb 2013, 19:53

Hi Simon,

It could be the R8 resistor:
http://www.ghd-repair.co.uk/r8_resistor.html

Also worth checking the debug guide:
http://www.ghd-repair.co.uk/mk4_debug.html

Gary


Return to “GHD 4.0B”

Who is online

Users browsing this forum: No registered users and 3 guests